Announcement

Collapse
No announcement yet.

Unity & C4D questions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unity & C4D questions

    Prof Watkins

    Regarding charactor movement in Unity: How do I get the charactor to fall in the pool or sauna created in the steam rm? I have re-created the Unity steam room document from last Friday and my first person shooter only wants to skate across the top of the water plane not fall into the pool or sauna, (drown damnit!). However it doesn't have issues with falling off the edge of the scene---how do I restrict it so he/she/it doesn't commit suicide? It do be funny though to watch the translate as it falls to infinity....aaaahhh!

    Moving on to C4D ---some of my baked materials look pretty darn bad. Post baked textures from the larger objects like the walls/terrace are looking a lot different from the pre-baked textures...like at a different scale or orientation, (the smaller ones don't have this issue, I am baking at 1024x1024, and the illumination is on). I've blasted a fair amount of light on them. Strangely the bigger ones seem to bake pretty quick compared to other smaller objects in the model ---wondering if C4D just doesn't like the material itself and craps out. Is it possible to scale these textures or change the UV mapping after baking? Any tips on getting the bake right whilst I do trial and error on this? I may send you an example of just a couple object before and after---the complete model files are too big for the forum now even if they are zipped.

    Thanks a lot!
    Monique

  • #2
    Originally posted by monique3232 View Post
    Regarding charactor movement in Unity: How do I get the charactor to fall in the pool or sauna created in the steam rm? I have re-created the Unity steam room document from last Friday and my first person shooter only wants to skate across the top of the water plane not fall into the pool or sauna, (drown damnit!). However it doesn't have issues with falling off the edge of the scene---how do I restrict it so he/she/it doesn't commit suicide? It do be funny though to watch the translate as it falls to infinity....aaaahhh!
    That water plane was created in C4D, so it has a collider. If you select the plane (just the plane) look in the Inspector window for a component called "Mesh Collider". Right click on that component and select "Remove Component." You should then drop right into the pool (through the water plane).

    As for falling off the world, one solution is to create some blocks in C4D that block off the areas that you can fall off the world in. Then, in Unity, select them and look at the Inspector window. There click off the "Mesh Renderer" check box. That will make it so you have some invisible blocks that won't let you pass, and so you wont' be able to fall off the space.

    Originally posted by monique3232 View Post
    Moving on to C4D ---some of my baked materials look pretty darn bad. Post baked textures from the larger objects like the walls/terrace are looking a lot different from the pre-baked textures...like at a different scale or orientation, (the smaller ones don't have this issue, I am baking at 1024x1024, and the illumination is on). I've blasted a fair amount of light on them. Strangely the bigger ones seem to bake pretty quick compared to other smaller objects in the model ---wondering if C4D just doesn't like the material itself and craps out. Is it possible to scale these textures or change the UV mapping after baking? Any tips on getting the bake right whilst I do trial and error on this? I may send you an example of just a couple object before and after---the complete model files are too big for the forum now even if they are zipped.
    Monique
    Baking can be tricky. It is true that when you bake, C4D re-uv maps the objects it's baking. Usually (unless you've defined the UVs in BodyPaint or something like that) this is a good thing. Remember that when you bake in C4D, it previews that texture as a very low-rez version; and so it looks pretty crummy in C4D. After you've baked, double-click on the baked material in the materials editor. click on the "Editor" section and change the "Texture Preview Size" to 1024x1024 to see your baked texture at full rez.

    But watch out, if you do this to very many textures, your video card will slow to a crawl and make it pretty hard to continue working with your model. I usually up the Texture Preview Size just long enough to see if it's really looking like I want, and then turn it back down to the "Default" setting.

    Comment


    • #3
      Great Thanks! I continue to build and experiment with these two programs...
      Have a nice day...

      Comment

      Working...
      X